use strict;
my $str = '<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>';
my $regex = qr/(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]/up;
my $subst = '<p class="foo">';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";