import re
regex = re.compile(r"(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]", flags=re.UNICODE)
test_str = "<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>"
subst = "<p class=\"foo\">"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)