// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]").unwrap();
let string = "<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>";
let substitution = "<p class=\"foo\">";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}