import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p class="foo">"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}