const regex = /(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p>)[\\x{0590}-\\x{05ff}\\x{0600}-\\x{06ff}]', 'u')
const str = `<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>`;
const subst = `<p class="foo">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);