re = /(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]/
str = '<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>'
subst = '<p class="foo">'
result = str.sub(re, subst)
# Print the result of the substitution
puts result