$re = '/(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]/u';
$str = '<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>';
$subst = "<p class=\"foo\">";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;