#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*StringToSearch:\n[^\n]+"
Local $sString = "Lorem ipsum dolor sit amet " & @CRLF & _
" StringToSearch:" & @CRLF & _
" | isoCode |" & @CRLF & _
"" & @CRLF & _
"consectetur adipiscing elit" & @CRLF & _
" StringToSearch:" & @CRLF & _
" | isoCode |" & @CRLF & _
"" & @CRLF & _
"sed do eiusmod tempor incididunt " & @CRLF & _
"ut labore et dolore magna aliqua " & @CRLF & _
" StringToSearch:" & @CRLF & _
" | isoCode |" & @CRLF & _
""
Local $sSubst = "$&\n\t\t\t| uk |"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)