import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*StringToSearch:\\n[^\\n]+";
final String string = "Lorem ipsum dolor sit amet \n"
+ " StringToSearch:\n"
+ " | isoCode |\n\n"
+ "consectetur adipiscing elit\n"
+ " StringToSearch:\n"
+ " | isoCode |\n\n"
+ "sed do eiusmod tempor incididunt \n"
+ "ut labore et dolore magna aliqua \n"
+ " StringToSearch:\n"
+ " | isoCode |\n";
final String subst = "$&\\n\\t\\t\\t| uk |";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}