re = /^\s*StringToSearch:\n[^\n]+/m
str = 'Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
'
subst = '$&\\n\\t\\t\\t| uk |'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result