using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*StringToSearch:\n[^\n]+";
string substitution = @"$&\n\t\t\t| uk |";
string input = @"Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}