import re
regex = re.compile(r"^\s*StringToSearch:\n[^\n]+", flags=re.MULTILINE)
test_str = ("Lorem ipsum dolor sit amet \n"
" StringToSearch:\n"
" | isoCode |\n\n"
"consectetur adipiscing elit\n"
" StringToSearch:\n"
" | isoCode |\n\n"
"sed do eiusmod tempor incididunt \n"
"ut labore et dolore magna aliqua \n"
" StringToSearch:\n"
" | isoCode |\n")
subst = "$&\\n\\t\\t\\t| uk |"
result = regex.sub(subst, test_str)
if result:
print(result)