$re = '/^\s*StringToSearch:\n[^\n]+/m';
$str = 'Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
';
$subst = "$&\n\t\t\t| uk |";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;