use strict;
my $str = 'Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
';
my $regex = qr/^\s*StringToSearch:\n[^\n]+/mp;
my $subst = '$&\\n\\t\\t\\t| uk |';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";