import Foundation
let pattern = #"^\s*StringToSearch:\n[^\n]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$&\n\t\t\t| uk |"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)