package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*StringToSearch:\n[^\n]+`)
var str = `Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
`
var substitution = "$&\n\t\t\t| uk |"
fmt.Println(re.ReplaceAllString(str, substitution))
}