# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+?)(?:(,)|$)/$1.DWH_JOB_ID$2\n/g;t' <<< "REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss"