import Foundation
let pattern = #"(\w+?)(?:(,)|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.DWH_JOB_ID$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)