use strict;
my $str = 'REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss';
my $regex = qr/(\w+?)(?:(,)|$)/p;
my $subst = '$1.DWH_JOB_ID$2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";