re = /(\w+?)(?:(,)|$)/
str = 'REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss'
subst = '$1.DWH_JOB_ID$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result