$re = '/(\w+?)(?:(,)|$)/';
$str = 'REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss';
$subst = "$1.DWH_JOB_ID$2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;