import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+?)(?:(,)|$)";
final String string = "REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss";
final String subst = "$1.DWH_JOB_ID$2\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}