const regex = /(\w+?)(?:(,)|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+?)(?:(,)|$)', 'g')
const str = `REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss`;
const subst = `$1.DWH_JOB_ID$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);