import re
regex = re.compile(r"(\w+?)(?:(,)|$)")
test_str = "REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss"
subst = "$1.DWH_JOB_ID$2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)