using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+?)(?:(,)|$)";
string substitution = @"$1.DWH_JOB_ID$2\n";
string input = @"REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}