#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)public\s+\$version\s+?=\s+'"
Local $sString = "public $version = '1.1.1'" & @CRLF & _
"some words before public $version = '1.1.1'" & @CRLF & _
"public $version = '1.1'" & @CRLF & _
"public $version = '1.1.10'" & @CRLF & _
"public $version = '1.1.10.1'" & @CRLF & _
"public $version = '10.1'" & @CRLF & _
"public $version = '10.1.10'" & @CRLF & _
"public $version = '10.10.10'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")