re = /public\s+\$version\s+?=\s+'/m
str = 'public $version = \'1.1.1\'
some words before public $version = \'1.1.1\'
public $version = \'1.1\'
public $version = \'1.1.10\'
public $version = \'1.1.10.1\'
public $version = \'10.1\'
public $version = \'10.1.10\'
public $version = \'10.10.10\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end