// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)public\s+\$version\s+?=\s+'").unwrap();
let string = "public $version = '1.1.1'
some words before public $version = '1.1.1'
public $version = '1.1'
public $version = '1.1.10'
public $version = '1.1.10.1'
public $version = '10.1'
public $version = '10.1.10'
public $version = '10.10.10'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}