import Foundation
let pattern = #"public\s+\$version\s+?=\s+'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public $version = '1.1.1'
some words before public $version = '1.1.1'
public $version = '1.1'
public $version = '1.1.10'
public $version = '1.1.10.1'
public $version = '10.1'
public $version = '10.1.10'
public $version = '10.10.10'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)