import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public\\s+\\$version\\s+?=\\s+'";
final String string = "public $version = '1.1.1'\n"
+ "some words before public $version = '1.1.1'\n"
+ "public $version = '1.1'\n"
+ "public $version = '1.1.10'\n"
+ "public $version = '1.1.10.1'\n"
+ "public $version = '10.1'\n"
+ "public $version = '10.1.10'\n"
+ "public $version = '10.10.10'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}