const regex = /public\s+\$version\s+?=\s+'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public\\s+\\$version\\s+?=\\s+\'', 'gm')
const str = `public \$version = '1.1.1'
some words before public \$version = '1.1.1'
public \$version = '1.1'
public \$version = '1.1.10'
public \$version = '1.1.10.1'
public \$version = '10.1'
public \$version = '10.1.10'
public \$version = '10.10.10'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}