use strict;
my $str = 'public $version = \'1.1.1\'
some words before public $version = \'1.1.1\'
public $version = \'1.1\'
public $version = \'1.1.10\'
public $version = \'1.1.10.1\'
public $version = \'10.1\'
public $version = \'10.1.10\'
public $version = \'10.10.10\'';
my $regex = qr/public\s+\$version\s+?=\s+'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}