import re
regex = re.compile(r"public\s+\$version\s+?=\s+'", flags=re.MULTILINE)
test_str = ("public $version = '1.1.1'\n"
"some words before public $version = '1.1.1'\n"
"public $version = '1.1'\n"
"public $version = '1.1.10'\n"
"public $version = '1.1.10.1'\n"
"public $version = '10.1'\n"
"public $version = '10.1.10'\n"
"public $version = '10.10.10'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")