$re = '/public\s+\$version\s+?=\s+\'/m';
$str = 'public $version = \'1.1.1\'
some words before public $version = \'1.1.1\'
public $version = \'1.1\'
public $version = \'1.1.10\'
public $version = \'1.1.10.1\'
public $version = \'10.1\'
public $version = \'10.1.10\'
public $version = \'10.10.10\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);