using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public\s+\$version\s+?=\s+'";
string input = @"public $version = '1.1.1'
some words before public $version = '1.1.1'
public $version = '1.1'
public $version = '1.1.10'
public $version = '1.1.10.1'
public $version = '10.1'
public $version = '10.1.10'
public $version = '10.10.10'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}