# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$/$1/gm;t' <<< "SS~B66\88~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~MEKLKE\M01~MOIIE
B~A310\0~PRELIM@INARY\00-00~HEADING"