use strict;
my $str = 'SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~MEKLKE\\M01~MOIIE
B~A310\\0~PRELIM@INARY\\00-00~HEADING';
my $regex = qr/^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";