// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$").unwrap();
let string = "SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~MEKLKE\\M01~MOIIE
B~A310\\0~PRELIM@INARY\\00-00~HEADING";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}