import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\n~]+~[^\\n~\\\\]+(?:\\\\[^\\n~]+~[^\\n~\\\\]+)+$";
final String string = "SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES\n"
+ "SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES\n"
+ "SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES\n\n"
+ "SS~B66\\88~MEKLKE\\M01~MOIIE\n"
+ "B~A310\\0~PRELIM@INARY\\00-00~HEADING";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}