using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$";
string substitution = @"$1";
string input = @"SS~B66\88~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~MEKLKE\M01~MOIIE
B~A310\0~PRELIM@INARY\00-00~HEADING";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}