import Foundation
let pattern = #"^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SS~B66\88~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~MEKLKE\M01~MOIIE
B~A310\0~PRELIM@INARY\00-00~HEADING
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)