const regex = /^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n~]+~[^\\n~\\\\]+(?:\\\\[^\\n~]+~[^\\n~\\\\]+)+$', 'gm')
const str = `SS~B66\\88~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\\M01~HEADING PAGES
SS~B66\\88~MEKLKE\\M01~MOIIE
B~A310\\0~PRELIM@INARY\\00-00~HEADING`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);