#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$"
Local $sString = "SS~B66\88~PRELIMINARY PAGES\M01~HEADING PAGES" & @CRLF & _
"SS~B66\88~PRELIMINARY PAGES~HEADING PAGES" & @CRLF & _
"SS~B66~PRELIMINARY PAGES\M01~HEADING PAGES" & @CRLF & _
"" & @CRLF & _
"SS~B66\88~MEKLKE\M01~MOIIE" & @CRLF & _
"B~A310\0~PRELIM@INARY\00-00~HEADING"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)