package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\n~]+~[^\n~\\]+(?:\\[^\n~]+~[^\n~\\]+)+$`)
var str = `SS~B66\88~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~PRELIMINARY PAGES~HEADING PAGES
SS~B66~PRELIMINARY PAGES\M01~HEADING PAGES
SS~B66\88~MEKLKE\M01~MOIIE
B~A310\0~PRELIM@INARY\00-00~HEADING`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}