# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("(?:logo_image_url|content_image_url)"\s*:\s*)".*?"/\1""/g;t' <<< "{ \"list\" :
[
{
\"id\" : 123,
\"name\" : \"some name\",
\"description\" : \"Lorem ipsum\",
\"logo_image_url\": \"222.png\",
\"content_image_url\" : \"1355.png\"},
{
\"id\" : 123,
\"name\" : \"some other name\",
\"description\" : \"Lorem ipsum\",
\"logo_image_url\": \"111.png\",
\"content_image_url\" : \"1355.png\"
}
]
}"