using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""(?:logo_image_url|content_image_url)""\s*:\s*)"".*?""";
string substitution = @"\1""";
string input = @"{ ""list"" :
[
{
""id"" : 123,
""name"" : ""some name"",
""description"" : ""Lorem ipsum"",
""logo_image_url"": ""222.png"",
""content_image_url"" : ""1355.png""},
{
""id"" : 123,
""name"" : ""some other name"",
""description"" : ""Lorem ipsum"",
""logo_image_url"": ""111.png"",
""content_image_url"" : ""1355.png""
}
]
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}