const regex = /("(?:logo_image_url|content_image_url)"\s*:\s*)".*?"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("(?:logo_image_url|content_image_url)"\\s*:\\s*)".*?"', 'g')
const str = `{ "list" :
[
{
"id" : 123,
"name" : "some name",
"description" : "Lorem ipsum",
"logo_image_url": "222.png",
"content_image_url" : "1355.png"},
{
"id" : 123,
"name" : "some other name",
"description" : "Lorem ipsum",
"logo_image_url": "111.png",
"content_image_url" : "1355.png"
}
]
}`;
const subst = `\1""`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);