import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"(?:logo_image_url|content_image_url)\"\\s*:\\s*)\".*?\"";
final String string = "{ \"list\" : \n"
+ " [\n"
+ " {\n"
+ " \"id\" : 123,\n"
+ " \"name\" : \"some name\",\n"
+ " \"description\" : \"Lorem ipsum\",\n"
+ " \"logo_image_url\": \"222.png\",\n"
+ " \"content_image_url\" : \"1355.png\"},\n\n"
+ " { \n"
+ " \"id\" : 123,\n"
+ " \"name\" : \"some other name\",\n"
+ " \"description\" : \"Lorem ipsum\",\n"
+ " \"logo_image_url\": \"111.png\",\n"
+ " \"content_image_url\" : \"1355.png\"\n"
+ " }\n"
+ " ]\n"
+ "}";
final String subst = "\\1\"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}