import Foundation
let pattern = #"("(?:logo_image_url|content_image_url)"\s*:\s*)".*?""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{ "list" :
[
{
"id" : 123,
"name" : "some name",
"description" : "Lorem ipsum",
"logo_image_url": "222.png",
"content_image_url" : "1355.png"},
{
"id" : 123,
"name" : "some other name",
"description" : "Lorem ipsum",
"logo_image_url": "111.png",
"content_image_url" : "1355.png"
}
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)