// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("(?:logo_image_url|content_image_url)"\s*:\s*)".*?""#).unwrap();
let string = "{ \"list\" :
[
{
\"id\" : 123,
\"name\" : \"some name\",
\"description\" : \"Lorem ipsum\",
\"logo_image_url\": \"222.png\",
\"content_image_url\" : \"1355.png\"},
{
\"id\" : 123,
\"name\" : \"some other name\",
\"description\" : \"Lorem ipsum\",
\"logo_image_url\": \"111.png\",
\"content_image_url\" : \"1355.png\"
}
]
}";
let substitution = "\\1\"\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}